Oracle 12c 连接时报错:ORA-28040: No matching authentication protocol问题解决方法

问题描述:

客户端连接Oracle 12c的时候,报错误:

ORA-28040: No matching authentication protocol


问题原因:

oracle 12c的参数SQLNET.ALLOWED_LOGON_VERSION默认等于11。当我们使用11g JDBC之前版本的thin驱动连接的时候,就会报错。


解决方法:

数据库服务器上的oracle/network/admin/sqlnet.ora文件添加一行SQLNET.ALLOWED_LOGON_VERSION=8,重启数据库,重新连接数据库,可以成功连接,问题解决。

方法二:

该错误出现的原因是:1.你安装的oracle版本不支持你设置的运行链接。

                                    2.可能是引入了的ojdbc14.jar出错。

解决方案:1.找到你Oracle安装包下的sqlnet.ora文件。(我的文件路径在:E:\app\yuanshu\product\12.1.0\dbhome_1\NETWORK\ADMIN\sqlnet.ora)可做参考。

                  2.为oracle数据库添加支持的版本链接。添加语句为:

                     SQLNET_ALLOWED_LOGON_VERSIONS=(12,11,10,9,8,7)

                     注: 该语句表示支持oracle7-12版本的链接。

                  3.将ojdbc14.jar替换为ojdbc6.jar.

                    (ojdbc14.jar支持JDK1.4,是老式版本,当中存在一些bug。ojdbc6.jar支持JDK6)


特别建议:Oracle9.0以后的版本都建议使用:“oracle.jdbc.OracleDriver”加载驱动类,而不再使用“oracle.jdbc.driver.OracleDriver”.


已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页